Post things only shitty programmers say

Post things only shitty programmers say

Attached: night_elf.jpg (900x675, 203K)

Post things only shitty programmers say

Let me Google that for a second.

"You need the internet to program!"

I use Linux for programming.

>Arrays should start at 1

unused ram is wasted ram ^_^

lmao, all of webdev btfo

>dark themes make me more productive

Who says that

I guy I worked with that only knew python and used only single letter variables

Attached: IMG1158090593.jpg (717x717, 56K)

That's true... from operating system perspective.

But Python counts arrays from 0

Attached: batman_confused.jpg (450x708, 572K)

>while (condition == true)

LUA scripters

>make a game in whatever language you want, it doesn't matter.
>better yet, use unity or unreal

That's actually legit for some cases where you want to be explicit.

This shit however, is never alright:
if (condition) return true;
else return false;

>only knew Python
>used only single letter variables
That's very common with mathematicians who pick up programming on the side, they still write their code like they write formulas on the chalkboard and it's not surprising that they'd want array indices to start from 1 because that's more familiar to them

You're right, it should be:
return (condition) ? true : false;

Fuck off sam. I know it's you.

>"It's just a temporary fix. I'll get back to it later."
>"You're having trouble? It works for me."
>"I don't need any comments."
And my favorite - rarer than the previous one, but always a gem:
>"My code is self explanatory. If you can't understand it, you're just not as smart as me."

Based and redpilled.

this should be banned. noone can read that

Attached: 1538920319050s.jpg (250x169, 5K)

My code is self documenting!

>That's easy to fix, just needs a third, maybe a fourth, nested For loop
>Asymp-whats-it behavior?
>Why use classes when I can just copy and paste?
>C is too low level to be useful

Also things only shitty programmers do:
>Create a 150 line program in only one function
>Use SQL, but employ cursors almost exclusively
>Don't comment their code, and produce minimal documentation
>Learn only one language
>Copy and paste chunks of code instead of exploiting inheritance.
>Fucking hard code everything.
When I first entered this industry I really did doubt my skills, having worked in it for a while I now understand that me fears were ill-founded.

Bonus! Things only shitty architects do:
>Constantly change your tech stack so that 2 years into a project you're still having basic arguments about languages and frameworks
>Be an architect that's worked heavily in X industry. Move into Y industry but still insist that Y can use the exact same technologies that X uses.
>Ignore all the advice from the devs that work daily with the current systems and understand their requirements.
>Come to a company at the "enterprise" level, but treat it as if it's a start-up.

The worst part is that, in my experience, this describes a big chunk of architects.

>"I don't need any comments."
Worst fad ever

I prefer using Xcode.

When do you add in comments? I'm new to programming myself.

bool isLessThanTen;
if (x < 10 == true) {
isLessThanTen = true;
}
else if (x < 10 == false) {
isLessThanTen = false;
}

if (isLessThanTen == true) {
return true;
}
else if (isLessThanTen == false) {
return false;
}

Because while it's nice if your code is clear it's much better to add a description for humans too. It costs nothing but some autists are actively avoiding it because muh self documenting code

Fuck having extra functions/methods, my main function will do everything.

I say that and I am a super shitty programmer :(

if ram is not being used then it's a waste. this is why every OS caches ram not in use.

When the method is or has to be lengthy or complicated looking.

When the method is creating a result that is counterintuitive or trying to fulfill an arbitrary client requirement.

When goes implementing something from a reference it can be good to link that reference.

When you're making a choice for an algorithm implementation it can be good to leave a line explaining that choice.

When you're creatinga series of methods or classes as an API or library, in which case over commenting and over communicating with users is probably better than not.

And lastly, when you'rewriting hobby code of any kind that you may not come back to for a while. You can be your worst enemy.

theres a guy I knew who deliberately used fucktarded variables so that his employers literally can't replace him because it's fucking hard to figure out the hell he was doing

like one would be aaao22211okk and another would be aaaoo2211okk

Everywhere you can, as detailed as you can. If more than half the file isn't comment, you're doing it wrong.
...Unless you're the only person who will ever see it. Then you can get away with describing functions, variables, and such. Writing down what you want the program to do is also good. No pressure, whatever's comfortable - so when you come back to it in 3 months, you still know what's going on.

reminds me of that one example where instead of using an array, the retard just made a shit load of variables called x, xx, xxx, xxxx, xxxxx, etc

>It costs nothing
But that is wrong.

A bad comment can be worse than no comment, as it can mislead other users or maintainers.

Likewise, other maintainers may change the function or comment in a way that renders the comment inaccurate.

In a team situation you must be prepared for and guard against other people making such mistakes.

in case anyone can't tell this idiot is trolling, just return condition

i tend to do this for high order functions & list transformations like arr.map(x => x.id)

>>The worst part is that, in my experience, this describes a big chunk of architects.
That's worrisome.

C# is better than C++

>A bad comment can be worse than no comment
So don't write bad comments

>That's worrisome.
Yes it is.

That's a dude!

"e-newm"

...

And in MATLAB they actually DO start from 1. Actually the most mind boggling decision I've seen in a a piece of software in a long time.

(if condition t)

Nah, no way a dude has that body shape

Just look at "her" face...

"javascript sucks"

This

it does. javascript is a meme. all javascript memeframeworks are also meme

Javacript DOES SUCK

I've seen more man-faced women before.

shitty "programmers" spotted

"Of course that's possible."

it's better imo from a readability pov

VB.Net programmers in my country are taught to use Call statement when calling a method.

Call Save()

Same result, but less retarded:
Save()

It really isn't if condition is already a boolean.

if (condition)
return condition;
else
return !condition;

>pythonic

t. shitty programmer

And "her" manly fingers...
Definitely a male...

smart guy

Saved for future work.
Also, you should not negate in last line except you want to return true always.

read one of your first more lengthy scripts you have written and try to figure out what you've hacked together. when you got it, put some comments in it. read it again 2 month later and find out why comments are useful.

Learn Java

The worst one I've ever heard
>I'm going to be coding this subruitine all night long if I gave you some cash could you go pick me up a sugar free monster from the circle K?

install gentoo

lol simply AMD™ Epyc™

It's because they wanted to comply with standard matrix notation. Typically rows are labelled i1,i2,i3... and they decided to break programming norms over matrix norms. Understandable since MATLAB was build around working with matrices, so there's a method to their madness

it's a good career

>I know how to write code in 7 different languages

It's usually beginners or people who have been programming for a year or two who list out languages they use as if it's the same as being fluent in real life languages. In reality, a decent programmer can pick up the syntax of almost any language in a few days. This also raises the point about what it means to "know" a language though. There's a huge huge difference in the number of people who write java code that compiles vs the number of people who understand the full complexity of everything happening in a piece of java code

If it isn't, that's a sign of being a bad programmer.

Tittys is tittys.

I'm guessing this is also why MATLAB, GNU Octave, and Mathematica index arrays from 1.

But many of these things can be described in the function names you use. I usually only comment when I figured out a particularly efficient but weird looking algorithm and my comment explains/proves that the approach works.
Otherwise, good function/argument/variable names do most of the documentation job

If you can't understand what it does just by looking at it for a couple of seconds, add a comment.

Javascript is actually a pretty amazing tool for the right job. Sure, driver development isn't one of those...

Wait, are single letter variables that bad?
I use single letter when use of variable looks obvious.
I feel like explanatory variables are useful only in OOP

remember that comments are for the people who come after you and have to maintain your code when they didn't write it. Or for you in like a year when you've forgotten all about everything you did. Shit that seems blindingly obvious and self-explanatory to you now (because you just wrote it) will seem very obscure to these future people.

I used i, j, k for loop in OOP.

Well, that's fine. I'm referring to objects variables

shitty idiot faget detected

comments add bloat to the binary and that's why i don't use them

i, j, k are ok for loop variables. Sometimes if you're defining a math operation, or some very generic operation, it's ok to use things like a, b, c, or x, y, z, or f, g, h, etc. For most cases, however, a variable name should clearly identify what semantics you assign to the value that it's going to hold. Otherwise you're a bad programmer AND a bad person.

came here to post this

that's what code reviews are for
if you're letting a single guy write all your shit for you with almost no oversight, then you either have tremendous trust in this guy or you're fucking retarded

>immediately after picking up legacy project.
> "This code sucks. We should rewrite it in {{new_trendy_framework}}
> Proceeds to give you and absurdly unrealistic time estimate for completion

Attached: 3f5a00acf72df93528b6bb7cd0a4fd0c.jpg (537x529, 32K)

what is a local web server

You don't need maths or logic.

Attached: 1513211884241.jpg (1071x419, 198K)

>hahaha you use X editor, how can you be even productive, I, use Y editor you know

>object oriented programming is bad

>monads

OOP is useful

>This looks like a job for ____ Pattern!

no

they should though.

doing length-1 is more common and annoying than any of its other downfalls.

C++ is too complicated.