Is this how boot camp grads into code

Is this how boot camp grads into code

Attached: A44B16A0-936E-4A19-8A0C-0C016EA1BF5D.png (750x1334, 153K)

>thinks xe can bootcamp ximself to a capable and cute programmer in a short amount of time

Attached: 1551985231298.gif (400x471, 289K)

Attached: CE2C1A38-07CC-4882-849A-D78F560507AF.png (854x380, 38K)

Not lucky? Not prepared!

can one of you bootcamp grads tell me what var = studying && hardwork is doing

>”getDevJob”
>returns a Boolean

Terrible code. This is better:

function getDevJob(studying, hardWork, luck) {
var isPrepared = studying && hardWork && luck;
if (isPrepared == true) {
return true;
} else {
return false;
}
}

It sets isPrepared to true if studying hardWork and luck are all true. The thing people are joking about is that since isPrepared is already a boolean, they could have just returned that value instead of checking it with a conditional.

>var

how to get vulnerabilities for free

Literally no difference. Everybody with at least 4.5 braincells knows what an if statement does.

const getDevJob = (studying, hardWork, luck) => studying && hardWork && luck;

I'm being sarcastic. The if is unnecessary.

I don't think you know what you're talking about at all.

Based trips triggers humorless Jow Forumstards

this

ABSOLUTELY TWISTED

function getDevJob(studying, hardWork, luck) {
var isPrepared = studying && hardWork && luck;
if (!(isPrepared == true)) {
return false;
} else {
return true;
}
}

Attached: joker leto.jpg (665x1000, 78K)

Boring.
const getDevJob = (...xs) => xs.every(x => x)

How unprofessional of you, this is how you get UB in your code.
function getDevJob(studying, hardWork, luck) {
var isPrepared = studying && hardWork && luck;
if (isPrepared == true) {
return true;
} else if (isPrepared == false) {
return false;
}
}

def getDevJob(stackoverflow, memelibrary, vagina, ethnicminority):
if vagina == True and ethnicminority == True:
hire(webDev)
return webDev.copyandpaste(stackoverflow)

Now anybody can insert any parameter they want and get the job. Good job, jolt.

const getDevJob = (...args) => args.reduce((a, b) => a && b);

Which they couldn't before?

Welp, I'm too used to Typescript. My bad, user sama.

Um no sweetie
int getDevJob(int, *)
{
if(studying)
{
If(hardWork)
{
If(luck)
{
return 1;
}
else
{
return 0;
}
else
{
return 0;
}
}
else
{
return 0;
}
}

C...can I join?
class ApplicantFilter {
...
boolean isApplicantFit(JobApplicant applicant) {
// basic background check
CV applicantCV = applicant.getCV();
if (applicantCV == null)
return false;
CVStudyItem[] studies = applicantCV.getStudies().filterByType(CV.HIGHER_ED);
if (studies.length == 0)
return false;
if (!this.checkDegreesForWhitelistedInstitutions(studies) &&
!RandomUtils.randBool())
return false;

// account for interview result
InterviewResult results = applicant.getInterviewResult();
if (results == null)
return false;
InterviewQuestionResult[] wbQuestions = results.filterByType(
InterviewQuestion.WHITEBOARD);
if (wbQuestions.length == 0)
return false;

int acceptedAnswers = 0;
for (InterviewQuestionResult q: wbQuestions)
acceptedAnswers += q.isAcceptedByInterviewer() ? 1 : 0;

if (acceptedAnswers < ((int) (wbQuestions.length * 0.8)))
return false;

if (applicant.getExpectedWage > ApplicantFilter.EXP_WAGE_THRESHOLD)
return false;

if (!applicant.acceptsOvertime())
return false;
return true;
}

import WebDevJob from 'DevJobs'

is this java?

js

function getDevJob(studying, hardWork, luck) {
var getPrepared = getStudying && getHardWork && getLuck;
if (getPrepared == true) {
return true;
} else {
return false;
}
}

you need naming consistency

>he declares variables with var

Attached: 1508255132712.png (1000x700, 101K)

>same naming convention for functions and variables
never gonna make it

based

This.

haHA so true xD

fixed it for realism
function getDevJob(studying, hardWork, luck) {
var isPrepared = studying && hardWork && luck;
if (isPrepared == true) {
return false;
} else {
return false;
}
}

function getDevJob(studying, hardWork, luck)
{
var isPrepared = studying && hardWork && luck;
return isPrepared;
}


:)

>resorting to dirty hacks and arcane practices instead of tried and proven methods
We'll call you.

Are you fucking retarded, you are an absolute fucking JavaScript nigger. If I didn't know better I would personally execute you with the sword of king Terry. I can smell your stinky fucking scripts from miles away. if you had even the tiniest brain you would realize how much of a nigger you are and you would instantly jump in front of a train.

You can literally just do

bool getDevJob(bool studying, bool isprepared, bool isluckyboi)
{
>return studying && isprepared && isluckyboi;
}

Ssst don't let the goyim know we need the code bases to be unmaintainable

Attached: 1551025936895.jpg (1242x1514, 1.12M)

This shit is wrong at so many levels...

Attached: 1550330887611.jpg (600x600, 44K)

His code is shaped like a handgun which he should use on himself

>just finished assembly section of cpu architecture class
REEEEEEEEEE SO MANY BRANCHES
ITS NOT EVEN INLINE

You shouldnt even be allowed to code unless you understand assembly and machine code

Why not just do
bool getDevJob = studying && isprepared && isluckyboi;
[\code]

>no arguments
D
B R A I N L E T
T
E
C
T
E
D

Dbtected

const getDevJob = 1;
Hired.

>using var when you should be using let
Dropped.

Someone needs to post the enterprise-quality Java implementation of this function.

isDeveloper
isIsDeveloper()

Isis

Or they could have just returned the truthy expression and not even need a variable

fuck spacing

Why not return isPrepared? It will work right?

>function getDevJob(studying, hardWork, luck) {
return (studying && hardWork && luck) ? true : false;
}

I'm not a programmer and even I know that functions are made so that you can reuse it.
What if user wants to apply for another job?

I would not write it like that, but it's actually more readable. Reads like english.

__inline bool getDevJob(bool studying, bool hardWork, bool luck)
{
return studying && hardWork && luck;
}

Your never gonna get a job without optimizing.

yikes

some compilers optimize for you, even if you don't want them to. Looking at you, gcc...

tertiary operators look ugly and I don't like using them

return studying && hardwork && luck

This is the correct answer.

These most definitely are not.

(every? identity [studying hardWork lucky])

what the...

>putting brackets for a single statement after an if statement

i dont want to use brackets like that but its not """"explicit"""" enough for some people apparently...

Google style guide

God I hate reading Jscript identation, triggers me every time.

Put your braces at the same identation level you absolute faggots!

I always do this. I always wrap my statements.
If I want to expand my statement I don't have to add them then and it makes zero difference to performance.

I want Sena to laugh at my mediocre coding skills

Attached: afdbd419591e59ec2c3d4f0f4a93f5e1.jpg (1200x1859, 614K)

It makes the joke better

Attached: 1403417457977.gif (650x422, 32K)

function getDevJob(studying, hardWork, luck)
{
var
isPrepared = studying && hardWork && luck;

return isPrepared;
}

fixed ;)

What if u changed the if to:
isPrepared ? True : False;

would you hire me?

//override for different jobs
public abstract class AbstractDevJobEvaluationManagerProvider implements AbstractStudyFactoryProvider, AbstractHardWorkFactoryProvider, AbstractLuckfactoryProvider {

private static final AbstractDevJobEvaluationManagerInstance = AbstractDevJobEvaluationManager ();

private AbstractDevJobEvaluationManager (){}

public static synchronized final AbstractDevJobEvaluationManagerInstanceProvider(){
return AbstractDevJobEvaluationManagerInstance ;
}

public static synchronized final AbstractDevJobEvaluationManagerEvaluationManagerFactoryBean(){

boolean studying = AbstractDevJobEvaluationManagerInstanceProvider().AbstractStudyFactoryProviderEvaluation();
boolean hardWork = AbstractDevJobEvaluationManagerInstanceProvider().AbstractHardWorkFactoryProvider();
boolean luck = AbstractDevJobEvaluationManagerInstanceProvider().AbstractLuckfactoryProvider ();

if(studying == true && hardWork == true && luck == false){
return false;
}
if(studying == true && hardWork == false && luck == true){
return false;
}
if(studying == true && hardWork == false && luck == false){
return false;
}
if(studying == false && hardWork == true && luck == true){
return false;
}
if(studying == false && hardWork == true && luck == false){
return false;
}
if(studying == false && hardWork == false && luck == true){
return false;
}
if(studying == false && hardWork == false && luck == false){
return false;
}
if(studying && hardWork && luck){
return true;
}
}

}

Attached: 1550685744849.jpg (729x729, 109K)

> t. never used gcc

sadly that isn't true, look at literally every website that exists. they're all shit.

You are like a baby. Hold me beer.
function getDevJob(studying, hardWork, luck) {
if (studying == false) {
return false;
} else if (hardwork == false) {
return false;
} else if (luck == false) {
return false;
} else {
return true;
}

const getDevJob = !studying && !hardwork && luck && stackOverflow && ctrl-v

too many if statements and too optimistic

function getDevJob(studying, hardWork, luck)
{
var isPrepared = studying && hardWork && luck;
if (isPrepared) return !isPrepared;
else return isPrepared;
}

Congrats, you're now the lead dev.

>Terrible code. This is better:
>
>function getDevJob(studying, hardWork, luck) {
var isPrepared = studying && hardWork && luck;
if (isDaddyManager == true) {
return true;
} else {
return false;
}
}

based and cpilled

ha ha
ha ha

ha ha
ha ha

ha ha

t. apple developper

Attached: gotofail.jpg (616x350, 102K)

Why is it so fucking hard to have an actually functional search function on a website? FUCKING WHY

Because unless they're using something dedicated to search (basically just elastic) then your typos are impossible to realistically implement.
You're basically asking "why can't I run a query on every search to scan absolutely every word in every item in the DB for similar words, and also have a dictionary of similar words for every single word in the DB"

Yeah, i guess that's the point of the thread

function getDevJob(studying, hardWork, luck)
{
var studying = studying;
if (studying == null) {
studying = false;
}

var hardWork = hardWork;
if (hardWork == null) {
hardWork == false;
}

var luck = luck;
if (luck == null) {
luck = false;
}

if (studying == false && (hardWork == true || hardWork == false) && (luck == true || luck == false)) {
return false;
}

if (hardWork == false && (studying == true || studying == false) && (luck == true || luck == false)) {
return false;
}

if (luck == false && (studying == true || studying == false) && (hardWork == true || hardWork == false)) {
return false;
}

return false;
}

I love how similar Javascript is to Perl these days.

Post archive link faggot.

Now make the bottom one into code

Attached: 1552080736765.jpg (1000x1000, 174K)

>passing studying, hard work and luck as arguments to a function
Whoa so this is the power of normie programming.

require("has-friends")

function getDevJob(studying, hardWork, luck, employer) {
studying = !!studying;
hardWork = !!hardWork;
luck = !!luck;

return hasFriends.atCompany(employer);
}

>doesn't post the article
what is the purpose of this thread

true code artisan here

Where is that from?

what language is this

its not python, but has (((dynamic typing)))

the most cancerous brainlet language that is the most popular one at the same time

but like I said, its not python