CamelCase vs snake_case

I heard one makes you a sexually confused mindless doll full of onions and estrogen, but which is it?

Attached: slide_casing-620x465-100297604-gallery.idge.jpg (620x465, 37K)

camel case by default but I have no problem using snake if it's according to the existing style

case sensitivity was a mistake

this

PascalCase for public members
camelCase for scoped identifiers
_camelCase for private members

What would you do to replace it?

case insensitivity

snake_case is objectively more readable.

snek is gud

DOSCASE
upper case only and maximum 8 chars

>php, scala
yes, any decent php project is going to be PSR-4 compliant, which calls for camelCase methods. this data shows nothing. The data in the pie chart that shows otherwise is eithe scala which is just dumb shit, or an amateur php project.

>snek case
You mean snail case?

flowmatic-case

you programming language doesn't support using spaces in your variable names, what is this 1999?

kebab-kase
objectively best no argument

Why would you want spaces that sounds retarded from a number of viewpoints

Attached: yotsuba.jpg (236x359, 28K)

>Whywouldyouwantspacesthatsoundsretardedfromanumberofviewpoints

snake

In a variable name? You really want to write a compiler that takes into account variables having spaces in them? Fuck that, a lot of work for absolutely no gain, it would just make code more illegible anyways

Attached: maho.jpg (435x463, 25K)

this

Attached: 1508735084606.png (400x400, 208K)

snake_case for functions and namespaces, camelCase for variable names

PascalCase for functions
UPPERCASE for structs
pxfHungarianNotation for variables

i should write a parser that will take anything between keywords and operators as variable name, including spaces. Just to fuck with you.

i think you mean PascalCase for types

it doesn't take any work at all and already exists.
code legibility doesn't matter in a world where ides exist

Probably the most retarded post I have ever read

Attached: retard.gif (400x225, 1.58M)

Patrician taste, right here.

snake_case for variables and functions
PascalCase for types
camelCase never ever

It's not efficient since converting variable names to lower case every single reference adds up.

Forget those, fuckyoucase is where it's at.

brainlet

java is a disease of the mind and soul

but seriously snake_case is better

lowercase

>not using different styles to carry information about what a name is
Variables and methods? camelCase.
Classes? PascalCase.
Functions outside of classes? snake_case.
Preprocessor macross? BIG_SNAKE_CASE.

>lowercase
You cannot have spaces in variable names. Do you mean snake_case or unreadablecasebecauseitsalljuststucktogether?

see

>You use PascalCase
>Turns out you're a minirity

Attached: 1320391885600.gif (464x260, 422K)

>Scala, PHP

>"item"
>"newItem"
>"createNewItem"
>case of existing words changes when more words are prepended

I feel like programmers should be the type of people who are bothered by this

one of the many reasons to go based_case

camelCase_snake

Only complaints I have with snake_case are it's more irritating to type, and it looks ugly in variable width.

Pascal_camel_Snake_Case

I usually use REVERSEcAMELcASE

I introduce backwardsesac. You separate words in a name by putting alternating words forward and backward. Following the example in :
>item
>newmeti
>createwenitem

one less click on the shift key :^)

Why not just use PascalCase?

That's what I use.

this

"item" would be a class name, so it's always "Item" unless it's a variable but then you shouldn't give a fuck.
"newItem" is either a private method for a class, or a retarded class name (then it's "NewItem") which you should never use, or a variable for which you don't give a fuck.
"createNewItem" is a private method for a class. Could be CreateNewItem if it's public.

There's zero inconsistency with the naming pattern unless you're giving things retarded names.

lowercase.

functions go like,

> dothis(), dothat()

variables go like,

> storethis, storethat

In scala and php.

Microsoft style c++ and c# use pascal case for fucking everything.

>storethis, storethat
fuckyou, fuckthat

PascalCase for classes/modules
camelCase for functions/methods
snake_case (or nocase) for variables
ALL_CAPS for constants
kebab-case for filenames

> MyModule.myMethod(this_variable, SOME_CONSTANT, "that-filename")

>>storethis, storethat
>fuckyou, fuckthat

You read that just fine, didn't you. One less keystroke on the Shift and underscore key.

best-way-is-this-way

This guy gets it

Attached: nice desu ne.jpg (467x413, 26K)

Eh, what about when functions are variables

camelCase is the nigger of cases. snek is the patrician choice.

Attached: images (15).jpg (529x278, 16K)

this ascii table is setup so you just binary xor off the high bits to upcase.
'A' == 'a' ^ 32 /* returns true */
if you binary and a lower case letter in ascii by 31 it returns the control character
'c' & 31 == ^C /* returns true */

How's mine
class Some_class
{
void some_method();
}

It is de-facto harder to read, user. It isn't "just fine", not even close.

I don't know a single fucking language that uses snake case in class names.

the right answer is whatever style the standard library uses.

Follow the convention for the language you're in. Java? camelCase. Python? snek_case. If you don't do this, you're incompetent.

Stroustrup does it in his book

class someCLASS
{
void SOMEmethod();
}

Improved a bit. Saved a couple bytes.

The fuck is wrong with you idiots. Just follow the fucking style guide for the language you're in and stop being retards.

well then they're functions

That would be caving to Oracle's authoritarianism. They want to dictate just about everything about code style in Java. This is my bit of rebellion. I also refuse to use exceptions except where required by their API methods, and instead simply don't feed bad arguments into functions.

>Saved a couple bytes.
>In source code
>Where it matters the least

Well it shaved a few nanoseconds off the compile. Being Java the names also go into the final .class files so it does have some bearing there too.

Camel_Snake

Pas-cal_Ke-Bab_Sna-ke

That first letter being lower case really triggers my autism

How about acronyms and initialisms? ReplManager or REPLManager?

Once again, follow the style of the language. It's really not that hard to rtfm. In java or groovy, it would be ReplManager. In python or go, it would be REPLManager.

>Pas-cal_Ke-Bab_Sna-ke
Time for you to git gud. Here we have 4 variables, and we're gonna subtract 'em:
Pas minus cal_Ke minus Bab_Sna minus ke

None of the above.
r_e_p_l_manager

result = SomeObject.someFunction().some_property

I'll usually capitalize shit like this.

It depends on the language

camel_Snek()