/fglt/ - Friendly GNU/Linux Thread

Previous thread: Welcome to /fglt/ - Friendly GNU/Linux Thread.

Users of all levels are welcome to ask questions about GNU/Linux and share their experiences.

*** Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread ***

Before asking for help, please check our list of resources.

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine.
1) Use a live image and to boot directly into the GNU/Linux distribution without installing anything.
2) Dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
3) Go balls deep and replace everything with GNU/Linux.

Resources: Your friendly search engine, mailing lists...
>b-but what search engines respect my privacy and freedom of speech?
Try qwant, searx, ixquick or startpage.
>b-but what e-mail providers respect my privacy and freedom of speech?
Try disroot, autistici or aktivix

$ man %command%
$ info %command%
$ help %command%
$ %command% -h
$ %command% --help

Don't know what to look for?
$ apropos %something%

Check the Wikis (most troubleshoots work for all distros):

Jow Forums's Wiki on GNU/Linux: wiki.installgentoo.com/index.php/Category:GNU/Linux

>What distro should I choose?
>What are some cool programs?
>What are some cool terminal commands?
>Where can I learn the command line?
>Where can I learn more about Free Software?
>How to break out of the botnet?

/fglt/'s website and copypasta collection:
fglt.nl && p.teknik.io/wJ9Zy

Attached: 1524428582857.png (720x1120, 70K)

Other urls found in this thread:


Does anyone use Openbox? Is it any good? I used it back when #! was a thing, but switched over to i3 on debian after it died. Just wondering if it's worth another go

I use it with lxqt de on my archiso live.
it's pretty much not openbox at that point but you can still apply themes

>when you pay for 4chin pass to support hiroshimoot but the website has gotten fucked 3 times in 1 week already

........('(...´...´.... ¯~/'...')
..........''...\.......... _.·´


................[]...........( .´・_・ )
................||___.ノ(. つ¶つ¶____
........../ ̄:l: .―:l:――――:l:/___ヽ,―、_
..........| :|:./ E:|:.....EEEEl.:|:|:.......:  ̄ ̄.|| `l
....../  ̄ ̄ ̄ヽ ̄ヽEEEEl.:|:|:__:___.||._|
..../.....,●、.....| | 77777777 |:|...l, ―┴、-―-┴.、
....|...●|...|.●....| | //////////// .:|:| ./..........ヽ.........ヽ ∩.........∩
...ヽ....`●'........| | ====== :|:| | ===●== .l ===== | (´;ω;`)/
......ヽ____../_./. ̄ ̄ ̄ ̄~'ヽ_____/____ /  ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'"''''''''''''"'"''"'"'"'"''''''''

I'm trying to figure out how to edit the sourcecode for lightdm, but this is the first time I've done anything more complicated than fucking around with .conf files and I'm already totally lost. I've downloaded the full package and for the right version but have no clue what to actually do with them. I've checked the wiki and google as best I could, but I don't think I'm even using the right keywords (it doesn't help that the first two pages of results are all "HOW DO EDIT .CONF?!?!!?"

Can anyone point me in the right direction? All I wanted to do if have the greeter truncate the user name to skip any whitespaces at the beginning. I figured that would be a nice first step that'd let me dip my toes into more serious stuff, but I'm already floundering.

whats the difference between .local/share/bin and .local/bin ?

who /Qubes/ chad here

idk i use windows 10

>all that wasted space on the left
('(...´...´.... ¯~/'...')
..''...\.......... _.·´

Lads, I'm scared.
I tried using bluez to connect my new chink headphones. I tried it on w10 before and in Ubuntu 18.04.
Now I decided to get it running on gentoo.
Using bluetoothctl I followed the instructions and ended up with Failed to pair: org.bluez.Error.AuthenticationFailed

Even worse happens when I run "discoverable on" with my controller, it just sits on "Waiting for bluetoothd..." infinitely.

The bluetooth service is started on boot and definitely running.

bluez sucks balls, even when I can get it to pair with my bose headphones it takes about 2 minutes for it to pair

I noticed that it sucks, but I'd still like to not have to reboot to use my headphones.

Is there no alternative?

if they're both in $PATH then who cares
I think share means platform independent, just by googling the path name. so you could take that folder from one computer and use it in the home directory of another computer.
why have white spaces to begin with

whats some >confy xfce themes? trying to pimp ma ride

Not as far as i know, this is the only Bluetooth stack for the Linux kernel so far.
And yes, it's state is absolute mess, developers know that and nobody seems to care.

I have a habit of tapping the space bar a few times to wake the computer up, and this normally puts a space or two before the user name. It's a minor annoyance when my password isn't working because the field is " user01" instead of "user01" or whatever.

Yes, I can just learn to wake my machine up differently or start a new habit of hitting backspace a few times, but I decided to use this as an opportunity to advance beyond basic end user junk. Figured it was about time, y'know?

What a piece of shit, I spent like 3 hours fucking with this thing and it doesn't budge.

Thanks anyway, maybe one day

the systemd file-hierarchy only mentions ~/.local/bin
~/bin is a convention used by older stuff
I've never seen ~/.local/share/bin, but I know Debian's bash profile will add the others to your path

>but I decided to use this as an opportunity to advance beyond basic end user junk. Figured it was about time, y'know?
ok well it's written in C and the source code is on github. you might be able to figure out where in the code the greeter parses the input and just add some code to remove or ignore whitespace.
probably best to go to

Is there a program to run custom scripts (e.g. a script to select a monitor, a script to open a program with certain options, etc...) graphically? Just a Launcher where you type and it maybe has a small prompt, nothing more..
Something similar to dmenu (but dmenu is not actually built for this).

It's a start. Thanks user.

Why not dmenu? Just put the folder with your scripts into your PATH and dmenu will regpnize them. Anyway, look into rofi.

When installing new font should I use the opentype or truetype version?

Why not dmenu? Just put the folder with your scripts into your PATH and dmenu will reopnize them. Anyway, look into rofi it's a more advanced dmenu.

When installing a new font should I use the opentype or truetype version?

If I rice my Arch installation on one user, it will change for the others users?


Depending on where you "rice".
Everything in home directories stay user specific.
Things set in global directories such as /etc are system wide.

hey guys I installed kubuntu 18.04 and loving it so far.
is KDE neon as stable as kubuntu?

dmenu is juat a generic menu. It can do this just fine.

Is the GnuWin32 toolset the only reliable way to get Flex and Bison working on windows natively?

wow first time i see my oc used by someone else on Jow Forums
feels good desu

Okay, thanks.

Anyone care to help out why Fedora won't allow me to system-upgrade?

Shell just stops at this part.

Attached: 1501173689329.png (1366x768, 716K)

danger of having cups/avahi deamon installed? forgot to remove it, how fucked is my pc? ubuntu

Why are you scared? Gentoo can't break

Enjoy doing that with xfce lol
I only use it when space is a concern

I am having trouble remembering some of the hotkeys in vim surround. For example, to add quotes around a word you type ysiw
Why ys? It's not yank. Did the author just make this up?

what are all the packages i need to get the different panel layouts on mate tweak to work on arch?

is the fedora KDE spin a minimal installation?
or its just like Kubuntu?

looks like snapper failed, unknown config.
snapper configs should have been part of your installation I assume
/etc/snapper/congfigs should have them. I don't know what they're defaults for fedora is.

you can use the network installer and select just the desktop environment and it shouldn't come with extra programs (haven't tried kde but i know you can do this with xfce)

you're going to need to compile and install it yourself. you should probably try compiling the source code as is and seeing if it works. probably has some distribution specific patch or configuration you'll have to also follow.

Can anyone recommend a good browser for an old laptop? Compaq evo n400c, 256 MB RAM. If possible, one good for google docs and/or youtube.

why the fuck when I installed debian, in my OpengGL settings it said something like VMware someshit?

Is anyone else seriously annoyed sometimes that there is no way to mount a remote filesystem and see an accurate representation of the users and groups on the server?

Most protocols just completely throw it to the wind. And the ones that at least faithfully enforce the permissions and users/groups ownership rules still cannot allow me to see the real usernames or groupnames. Since all you actually get is the uid/gid as integers and your machine tries to map names to it from your own local machine.

It might be a minor thing, but it really upsets the shit out of my autism to see files appearing to be owned by the wrong users.
I know they can be correctly mapped, but it should be automated. Otherwise there is no guarantee that you have the most up to date map.

Ricing question: what's a good sound that I can use in place of the default KDE error sound.

any KDE neon user here?
whats the plasma version of the current user release?
is the distro stable?


kerberos or ldap and nfs

GNOME error bloop is the best

I don't know if this is possible, but I want to know if the mPCI-e slot on my laptop (HP 8470p) has a sata controller or not.
Is there anything similar to lspci that would list that?

lspci only lists one SATA controller (assuming that's for the 2.5" bay) but I know that the CD drive can take a hard drive so it's either not listing that or it's part of something else.
Just wondering if that's the case with the mPCI-e/mSATA slot.
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
00:16.3 Serial controller: Intel Corporation 7 Series/C210 Series Chipset Family KT Controller (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7
00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
Technology Corp. IEEE 1394 Host Controller (rev 30)
23:00.1 System peripheral: JMicron Technology Corp. SD/MMC Host Controller (rev 30)
23:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller (rev 30)
24:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)

Attached: Screenshot_20180407_235528.png (856x413, 375K)

sata and pci-e are two different buses
your question really doesn't make sense

It's late sorry
The machine has 2 pci-e slots, one occupied by the wifi card and another I'm assuming is for a mobile data option. I know some laptops like the x220 can take an mSATA SSD in the latter so I'm trying to figure out if this machine can do the same.
I'm seeing conflicting reports online, elitebooks aren't as popular as thinkpads sadly.

Why youtube cpu usage on linux is much higher then on windows? I guess it has something to do with gpu acceleration. How to fix (I am already using proprietary nvidia drivers)?

Attached: photo.jpg (640x639, 21K)

your motherboard or laptop manual will tell you the bus type/version and if it shares bandwidth with another bus or port.

as long as what you want to plug in fits it should work, unless your hardware isn't backward compatible with the motherboard bus version.

I tried to set up Debian sid with KDE, and it worked for until the KDE update manager started updating. The process was interrupted by my host turning itself off, and now Debian only boots into console (pic related).

What happened:
1. Set up Debian sid (as described in: youtube.com/watch?v=7khNDpDVMZ4)
2. Finish aptitude updates/upgrades, which took quite a while
3. After everything was done and looked good, the KDE update manager said there are still 628 updates to install
4. Open KDE update manager and click on update everything
5. During the very long installation process, the host machine turns itself off
6. After restarting everything Debian now only boots into console

I google the problem and found this: unix.stackexchange.com/questions/204387/debian-not-booting-into-gui#204408
I went through all posts stept by step, but nothing got KDE to start again (of course for display manager commands I used sddm, again pic related).

I don't want to do a fresh install right away, because of how long it took to set everything up, plus I don't want to repeat whatever mistake I might've made.

Attached: Capture.png (1440x926, 68K)

bitmap fonts don't render correctly in urxvt when i disable aliasing, how do i fix this?

the easiest way is to just remove the kde group and reinstall
then enable sddm with systemctl

>After everything was done and looked good, the KDE update manager said there are still 628 updates to install
>4. Open KDE update manager and click on update everything
this is where you fucked up

/usr/share/applications -> ~/.local/share/applications
/usr/share/man -> ~/.local/share/man
/usr/share -> ~/.local/share
/usr -> ~/.local
which means:
/usr/bin -> ~/.local/bin
makes sense now?

I want to squashfs a 11gb directory. Will this melt my toaster?

A gnome person wrote an article trying to defend gnome developers. lmao archive.is/kk3GM

I literally want gnome developers to die in accidents. I'm not just being edgy, I want tragedies to befall them for what they've wrought on the linux community. Yes, no software is better than bad software.

Attached: KlrbBMq.jpg (601x400, 117K)

I am a bit confused about ssh. If i log into my server over ssh and reverse redirect a port, does that mean that all users on the server can access that port now, or only the user as which the ssh is logged in as?

Is there a way to share my computer's internet connection with my smartphone (Android)? Basically a reverse tethering kind of scenario?

I'm looking online and I haven't been able to find anything.

>all that hate
Get rid of it.

>user is not in the sudoers file. This incident will be reported.
Why would i use a filthy snitch OS like this? At least windows values my privacy.

what is a wifi
it's reported to /var/spool/mail/user

Hey /fglt/. I don't have a lot of money, and can't afford to really back up a lot of my files at the moment. Even so, I'm getting really interested in Linux and want to switch over for my desktop browsing. I have a 250gb partition on one drive (currently NTFS, the other partition on the drive is NTFS as well but I want to leave that one alone) that I can easily clear out and wouldn't mind using. My question is, is it that simple? Can I just clear off that partition, format it, and install Linux in that space? I was thinking of Fedora, Void, or Arch.



check your browser settings
about://flags or something

otf is adobe invention, while
ttf is micropenis invention
so whichever it is doesn't really matter
>Can I just clear off that partition, format it, and install Linux in that space?
but be sure to try out gentoo

The font provider suggests to use the truetype version for Windows and Mac but says nothing about Linux...

Can anyone help me? I'm compiling my first project that I downloaded from github and I followed the instructions on the page but I'm getting errors


Unable to generate makefile for: /home/paddy/Downloads/mpc-qt/mpc-qt.pro

but when I do sudo qmake I get no output so I assumed it work and then when to do make[/make] I get:

paddy@T440 mpc-qt $ sudo make
/usr/lib/qt5/bin/lupdate -locations none -no-ui-lines /home/paddy/Downloads/mpc-qt/mpc-qt.pro
Updating 'translations/mpc-qt_it.ts'...
Found 829 source text(s) (0 new and 829 already existing)
Updating 'translations/mpc-qt_ru.ts'...
Found 829 source text(s) (0 new and 829 already existing)
/usr/lib/qt5/bin/lrelease translations/mpc-qt_it.ts -qm resources/translations/mpc-qt_it.qm
Updating 'resources/translations/mpc-qt_it.qm'...
Generated 687 translation(s) (678 finished and 9 unfinished)
Ignored 142 untranslated source text(s)
/usr/lib/qt5/bin/lrelease translations/mpc-qt_ru.ts -qm resources/translations/mpc-qt_ru.qm
Updating 'resources/translations/mpc-qt_ru.qm'...
Generated 387 translation(s) (382 finished and 5 unfinished)
Ignored 442 untranslated source text(s)
g++ -c -pipe -Wall -O2 -std=gnu++1y -Wall -W -D_REENTRANT -fPIC -DMPCQT_PREFIX=\"/usr/local\" -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_X11EXTRAS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_DBUS_LIB -DQT_CORE_LIB -I. -isystem /usr/include

I'm pretty sure I have the dependencies

/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtX11Extras -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtDBus -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -isystem /usr/include/libdrm -I. -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++ -o ipcmpris.o ipcmpris.cpp
In file included from ipcmpris.cpp:7:0:
mpvwidget.h:13:10: fatal error: mpv/render.h: No such file or directory
compilation terminated.
Makefile:785: recipe for target 'ipcmpris.o' failed
make: *** [ipcmpris.o] Error 1

shrink the existing partition by 20gb and install something like xubuntu

github.com/grugq/urxvt-ctx how would I install this onto urxvt? in /.urxvt/perl?

Hi friends, I'm on Arch and I just spent an hour troubleshooting and getting Oregano to work but it keeps crashing when I try to simulate.

Can anyone recommend a SPICE style circuit simulation program on the AUR?

>what is a wifi
My laptop's WLAN device can't create hotspots. I am disappointed because it's a Thinkpad T410 and I assumed Intel was better than this (they made the network device).
I've also just found out that despite having a SIM card slot, my T410 doesn't have a WWAN device.

It expects /usr/include/mpv/render.h:
Try recompile mpv from master branch with --enable-libmpv-shared.

sorry where would that command go? I installed mpv through discovery.

>inserting a useless "sudo" without knowing what it does or why it's used

Copy selection-ctx and table.txt file to /usr/lib*something*/urxvt/perl.
Put the following to ~/.Xresources:
URxvt.perl-ext-common: selection-ctx
and run:
xrdb ~/.Xresources

$ cd /path/to/mpv/repository
$ curl -LRo waf waf.io/waf-2.0.7
$ chmod +x waf
$ ./waf configure --prefix=/usr --enable-libmpv-shared
$ ./waf build

To install:
# ./waf install

thanks for your help. really new to linux. since I installed it through discovery/software centre I'm not sure where it went. I ran locate mpv but I'm not sure what I'm looking for, in windows I would look for a .exe in program files.

$ dpkg-query -L mpv
$ dpkg-query -L libmpv-dev

Looking for a distro for my thinkpad x220. What is /fglt/'s thoughts on Manjaro? I'm thinking of using the Architect .iso since Arch Linux is too in-depth for me at this point in time.

>since Arch Linux is too in-depth for me at this point in time.
try to install it. If you can't, try something else.
Giving up without trying is beyond retardation. You won't brick your hardware by installing or failing to install a linux distro.

I did try. I succeeded, I think. But it is too barebones. I don't want to install such-and-such a package and spend hours tailoring my x220. I would like to do it in the future as a big project but not right now. So I figure the Manjaro Architect image will be ok since it still seems basic but not as basic as Arch.

Install Gentoo.

>I did try. I succeeded, I think.
And by this I mean that I installed the OS successfully. But the steps to manage wireless networking and specific drivers for the x220 seem too large right now.

okay so I found something in /usr/include/mpv because that's where libmpv was (pretty much the same output as my locate in pastebin).
File "./waf", line 165, in
Scripting.waf_entry_point(cwd, VERSION, wafdir)
File "/usr/include/mpv/.waf-2.0.7-63e8685c267915c8f1b03d9a344b09f7/waflib/Scripting.py", line 101, in waf_entry_point
File "/usr/include/mpv/.waf-2.0.7-63e8685c267915c8f1b03d9a344b09f7/waflib/Scripting.py", line 141, in set_main_module
File "/usr/include/mpv/.waf-2.0.7-63e8685c267915c8f1b03d9a344b09f7/waflib/Context.py", line 356, in load_module
raise Errors.WafError('Could not read the file %r'%path)

Could not read the file '/usr/include/mpv/wscript'

$ ./waf configure --prefix=/usr --enable-libmpv-shared

Starting to frusterate me because some of these commands I have no idea what they are AND there's no guide on mpv when things go wrong.

...lspci is what lists it.

From my laptop:
02:04.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
02:04.3 SD Host controller: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller
30:00.0 Network controller: Broadcom Limited BCM4311 802.11a/b/g (rev 01)

See the numbers at the start?
Card reader is integrated, Wifi card is in a mini-PCI-E slot. Guess you should be able to see similar differences for your laptop.

how do programs from github or tar balls get updated?

When you make install them again.

so how do you keep up with updates?

git pull, recompile and reinstall
>source tarball
redownload again, unpack, import previous settings, recompile, reinstall
>binary tarball
delete old data, unpack