/fglt/ - friendly GNU/Linux thread

OLD: Welcome to /fglt/ - Friendly GNU/Linux Thread.

Users of all levels are welcome to ask questions about GNU/Linux and share their experiences.

*** Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread ***

Before asking for help, please check our list of resources.

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine.
1) Use a live image and to boot directly into the GNU/Linux distribution without installing anything.
2) Dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
3) Go balls deep and replace everything with GNU/Linux.

Resources: just like in /sqt/ spend at least a minute to check a web search engine with your question.
*Search: qwant, searx, ixquick or startpage.
*Many free software have active mailing lists.
*Many free software has an active bugzilla/github where you can check and report errors

$ man %command%
$ info %command%
$ help %command%
$ %command% -h
$ %command% --help

Don't know what to look for?
$ apropos %something%

Check the Wikis (most troubleshoots work for all distros):

Jow Forums's Wiki on GNU/Linux: wiki.installgentoo.com/index.php/Category:GNU/Linux

>What distro should I choose?
>What are some cool programs?
>What are some cool terminal commands?
>Where can I learn the command line?
>Where can I learn more about Free Software?
>How to break out of the botnet?

/fglt/'s website and copypasta collection:
fglt.nl && p.teknik.io/wJ9Zy

Attached: NicoBZH_-_Richard_Stallman_(by-sa)_(8).jpg (2021x2021, 1.23M)

Other urls found in this thread:


First for freedom

What is the best GNU program?

GNU Hurd


GCC, the only good GNU program.

nano has the cutest mascot

Attached: .jpg (650x465, 47K)

worst fucking text editor in existence


>worst fucking text editor in existence
Bold claim. Wonder why every distribution ships with it and every noon guide recommends it...

Not him, but that's because it's easy to understand. In that sense I think it's an a great default editor because even someone who's never used a terminal before can get stuck having to repair their system without a graphical interface and they can use nano to get the job done. Whereas with vim they'd probably be lost.

Whether or not it's good for daily use though is another story. I'd have to look more deeply into all the hotkeys available.

What's the best distro for running Wine?

I need something for chroot and I want to play 32/64 bit games.

Attached: consider_this_no_opinion.jpg (468x389, 111K)

Hey there, while installing Kali I had a dchp not detected or some error like that. I just clicked I'll set it up later.
Now wifi doesn't exist. It says "no wifi adapter found" in wifi settings. Internet does work through USB tether.
lspci says network controller is realtek.
How do I fix? Thanks

Does your wifi work when using kali through a live usb? If so I would consider just to try reinstalling.
Also kali tends to break because of the loads of packages, rolling release and such in my experience when having it installed. Im sticking with a liveboot usb.

Nop doesn't work in liveboot

My next step would be to figure out what kind of wifi-adapter Ive got in my system, and trying to find firmware for it to place in /lib/firmware/.
Or just google around trying to find others with the same chip and the same problem.

Non ironically Gentoo

Id say Ubuntu, just because the support on Ubuntu is pretty decent for what most (((people))) want (gaming), I haven't looked into it though.

Dubs and I invite my only friend and install gentoo in front of him (without genkernel, I configure EVERYTHING by hand)


>Non ironically Gentoo
It's a laptop using Intel U CPU. Not the best choice.

Thanks. Does it offer anything that Debian does not? Since I'm currently using sid for chroot.

Hope you do that naked.

Well... fuck

>Thanks. Does it offer anything that Debian does not? Since I'm currently using sid for chroot.
Like I said, I havent looked into it. But since all the cool kids are using Ubuntu, and Wine wants the biggest audience, Im guessing Wine's compatibility with Ubuntu is the best.
Although on the top of my head, I don't think Debian has any issues at all running Wine.

Ok, thanks again.
I'm just afraid that Debian is too old. I mean "st" in the repos is 3 years old and "wine" itself is 3.0 instead of 3.7


Oh wow even in sid? Then Im not sure. I think Wine really likes being the current version.
Game support and even performance increases with each update of course.

Attached: 1524091367438.jpg (400x597, 36K)

wine-development is 3.7 in sid
"development" is debian codeword for " not ancient"

>Using st from the repos
user what the flying fuck
The point of st is that you compile it from source yourself because you configure it from the source, you dum dum.

How do they mark development packages? As in "ncurses-devel"

>The point of st is that you compile it from source yourself because you configure it from the source, you dum dum.
Well, I'm using version from the PM while also configuring it with "xbps-src".
I needed in in Debian for terminfo. In the end I simply copied one from the host.

nope its called wine-development and i think wine is the only pacakge they do this with
*-devel packages usually hold the headers for whatever the base package is

anyone know of an image viewer which does "sort by date" ?
i've tried: eog, feh, gliv, gpicview, mirage,qiv

Try XnViewMP

Windowsfag here, how do I make Linux Mint's system font (via 'Font') look more like Windows 10? I have the Windows fonts package downloaded.

I've actually done this before in a room full of people, with the screen projected onto the wall.
It was after some conference and someone wanted help installing Gentoo. I guess others were interested too and stayed.
I don't think we got all the way through the kernel configuration though.

Any of you faggots used odroid xu4 as a daily driver?
I mean it looks decently powerful, linux support is hands down outstanding so it should work at least as a thin client or basic workstation.
Whats your opinions?

Attached: xu4.jpg (498x375, 38K)

So, let's imagine I wanna switch away from KDE to another DE.
I'd want:
>scaleable UI
>non-fixed taskbar/launcher
>virtual desktop in a grid-layout
>flat look
What DE would allow me to do this? And how would I do it without reinstalling over my currrent installation of 18.04?

If it had a SATA ports I'd say yes. Look around if you can find another board with similar specs but support for SATA.

>And how would I do it without reinstalling over my currrent installation of 18.04?

You just install the new DE metapackage and then you can select it from your login manager. Like
apt-get install xfce4 xfce4-goodies
The log out, select xfce in the login manager, log in and boom you have XFCE without sacrificing anything from KDE/Kubuntu

Nomacs. Free software, GPL3. Report bugs, help improve it.

Attached: 2018-05-03-194822_1280x800_scrot.png (880x621, 60K)

I'm looking for something like that. I just need a tiny computer with WLAN that I could connect to a hard drive to play music from. It should have a 3,5mm audio out. Is there something like that?
I only know of those small Raspberry Pi computers, but is there something else I should look into?

odroid, banana pi, cubieboard for example.

Most of these ARM mini-pcs
-can run Android
-can run GNU/Linux
-can run non-GNU/Linux, *BSDs, RISCOS and maybe other OS'
-have HDMI and 3,5" jack outputs

Some of them have gigabit ethernet, SATA, integrated wifi and/or bluetooth and Raspi-compatible GPIO interface so you can use gadgets designed for the pie without modifying their hardware.

It has usb3.0 and emmc5.0 sooo yea its nowhere near sata but it aint that bad. The other possibility is that odroid made a different version that has actual sata3.0 problem with that it doesnt have an hdmi out because it is a nas board (odroid hc1)

I'm getting the error "Device or resource busy" when trying to encrypt my drive.
How do I un-busy the drive? What could be causing it?

Attached: 1514013967111.jpg (2000x1287, 685K)

Kill me.
I ran --debug to see if I could find more info about what was happening and the thing decided to work.

use lsof

See Thanks anyways.

Banana pi and banana pros are cheap and old (old meaning they have stable linux images) and have a sata2.0 port and sata power port as well as 3.5 jack out. That makes them perfect for non-audiophile playback.
Anyway native sata isnt necessary as usb to sata adapters provide enough speed for music, but its another thing to buy so it increases overall price

Thanks, I found the Banana Pi on a local retailer. It's still somewhat more expensive than a Raspberry Pi.
Will the very first model of the RPi be enough for music playback? I mean, I assume it will and I don't really need the twice as expensive model.

Depending on what you will use to listen to music. If you are using mpd for example any ARM board will be able to handle it.

Yes, MPD and then control it via clients from my phone or laptop.

Regarding horsepower the first gen rpi has plenty to deal with music playback. But there will be an additional usb to sata adapter and some sata power cables so you have do the math: is the banana pi or the rpi+adapters are the more expensive.

>Get to the second step where I have to actually open the encrypted partition.
>Get the same error.
God dammit.
Anyways lsof doesn't seem to be a thing on the gentoo live CD.
This is absurd, I didn't have a single problem when I installed it normally, but setting up the encryption has me befuddled.

Audio over Displayport isn't working on my R9 380 and 4.15 kernel. I did find this guide but it says you have to mess with kernel parameters and stuff, so can anyone verify if it should work before I fuck something up?

>In an effort to bootstrap the GNU operating system, Richard Stallman asked Andrew S. Tanenbaum, the author of the Amsterdam Compiler Kit (also known as the Free University Compiler Kit) for permission to use that software for GNU. When Tanenbaum advised him that the compiler was not free, and that only the Free University kit was free, Stallman decided to write a new compiler.

Attached: stallman lan party.jpg (388x379, 32K)

Men, how do I find the corresponding names of keyboard layouts to use with "setxkbmap"?

I want to get away from KDE.
Budgy or Mate? Does Budgy support Hotcorners and virtual desktop grids?

Keyboards in X are the worse documented part of X. There is just a small incomplete doc written by someone who try reverse engineered keyboard in X.

I have an old netbook that I havent being using from long time wich I have Mint and Win7 (dual boot with grub). How can I update to the last version of Mint without fucking everything up? I want to keep Win7 and the files on it.

I need to update because the Mint is fucked up, Already downloaded and made a booteable usb stick with the last mint version. Please help.

Attached: 1313456456748.png (205x205, 58K)

I was toying around in Budgy and accidentally deleted the top panel with all its widgets and now I cant find a way back into the customization menu anymore. All I can get is the normal settings and I cant add/edit panels there.
Can anyone help me out?

nvmd fixed it myself

This might not be the best place to ask but I'm at a loss. Hard drive went belly up making it impossible to boot. I tried accessing the bios during boot and something happened, now it's completely dead (can't access bios, black screen, powers up normally). What the fuck happened? Before trying to access bios it was in bootloop because of the dead hard drive.

are you asking if trying to boot into a corrupted harddrive caused your cpu to die?

is there a way for me to filter through multiple directories at a time in order to find a file that meets specific conditions, like a specific file size for instance?

for loop

How do daemons actually work?
If I have the deluge daemon open, for example, what would happen? Will it seed stuff?
Please help, I'm a confused GNU/Linux newfag.

Afaik the UI cannot be scaled in xfce. Cinnamon I know can do this, not sure about virtual desktops since I don't have much use for them.

It's literally just a term for any program running in the background (without an interface).
I don't know what deluge is, I'm guessing a torrent client, so it'll probably seed shit I guess. The mere fact that it's running as a daemon doesn't give you any information about what it's doing. It's doing exactly whatever it was designed to do, just in the background.

Ok thanks user!

what are the most useful vim key mappings?

So, I have made a backup of my server using dd, and I intend to move it to proxmox. But, the iso is currently over 100GB as the drive used for the sever is a 120GB ssd. The drive only has maybe 40 - 50 GB used, the rest of the iso is literally empty space. How do I go about reducing the size of the iso so it's slightly bigger than the space actually used?

Attached: 1518255136949.gif (245x230, 879K)

can someone share their urxvt .Xresources config file?

i need some inspiration

So.... what's the deal with Roll Window Up/Down on XFCE?

Xft.autohint: 0
Xft.lcdfilter: lcddefault
Xft.hintstyle: hintslight
Xft.hinting: 1
Xft.antialias: 1
Xft.rgba: rgb

URxvt.font: xft:Source Code Pro:size=9.5,xft:DejaVu Sans Mono:size=9.5
URxvt.foreground: #D3D7CF
URxvt.letterSpace: -1

URxvt.background: #231F20
URxvt.transparent: true
URxvt.shading: 30
URxvt.cursorUnderline: true
!URxvt.scrollBar: false
URxvt.scrollstyle: plain
URxvt.geometry: 95x30

URxvt.scrollTtyOutput: false
URxvt.scrollWithBuffer: true
URxvt.scrollTtyKeypress: true
URxvt.secondaryScroll: false
URxvt.secondaryWheel: true

! Black + DarkGrey
*color0: #231F20
*color8: #737171
! DarkRed + Red
*color1: #EE2E24
*color9: #EE2E24
! DarkGreen + Green
*color2: #26CB6B
*color10: #26CB6B
! DarkYellow + Yellow
*color3: #FFD204
*color11: #FFD204
! DarkBlue + Blue
*color4: #009DDC
*color12: #009DDC
! DarkMagenta + Magenta
*color5: #D655DA
*color13: #D655DA
! DarkCyan + Cyan
*color6: #85CEBC
*color14: #85CEBC
! LightGrey + White
*color7: #D9D8D8
*color15: #FFFFFF

Did an update on my debian buster today, and now my haswell vulkan drivers are fucked. It just says error - vulkan: no DRI3 support when I try running either my own apps or the glxgears equivalent. DRI3 loads fine according to Xorg.0.log, so I'm not sure how to troubleshoot this

mount and cd into the disk image
dd if=/dev/zero of=1.txt
rm 1.txt
compress it with 7zip :^)

Pipe it through zstd (/use that compression at the filesystem or block level) or whatever you like. You'll still have to use transparent decompression until you at some point unfuck your ISO.

>fell for the 16GiB meme
Should have fallen for the 32GiB meme when it was less that 100 shekels.

Attached: Screenshot_2018-05-03_23-18-22.png (1856x149, 31K)

>Xft.autohint: 0
>Xft.lcdfilter: lcddefault
>Xft.hintstyle: hintslight
>Xft.hinting: 1
>Xft.antialias: 1
>Xft.rgba: rgb

who knows what that does

>URxvt.transparent: true
do i really get to see my desktop wallpaper?

>URxvt.shading: 30
>URxvt.cursorUnderline: true
>URxvt.scrollstyle: plain
>URxvt.geometry: 95x30

who knows what these do but im putting it in

Yes, for example this would find all files under /home and /etc recursively that are exactly 1024 bytes.
find /home /etc -type f -size 1024c -exec ls {} \+

man find


I used think that trying to resize windows was clunky compared to windows, but now my life has changed.

Any other cool tips and tricks?

>fell for 32 GiB meme
I figured I would buy another 32 to fill out my ram slots when they were cheaper. I just didn't think they would get more expensive.
The thing that gets me is virtual guests that eat ram

Attached: Screenshot from 2018-05-03 20-45-28.png (1333x135, 24K)

idk where to ask since google is not helpful
anybody have ovmf working in qemu/kvm win10 1803 (april update)?
non-efi firmware was able to update so must be something to do with ovmf and win10 1803

Attached: Screenshot from 2018-05-03 21-11-55.png (1280x826, 45K)

How on earth does one auto-mount network shares in fstab? I've added "auto" to the share I want mounted at startup but it has had no effect on getting what I want to happen.

Depends on if you want to back up files or back up the disk image. DD is great for making the disk image, and as instructed you can compress it with tools after creating the image.

but if your target of the backup is not practically the same disk (a migration perhaps?) then you'll have to copy the files to the new filesystem anyway. if you're at that point you can save some space by just backing up the filesystem with tar and compressing with xz or similar. Be sure to use tar in the most attribute-sensitive way (--xattrs -p).

You could mount your dd image and tar it as well if you've already got the image.

Attached: sas.jpg (1280x960, 57K)

systemd is straight forward

This doesn't seem to work. It seems like something is happening, but the share never mounts. Thanks anyway.

what does your journal say about it
journalctl -e after trying

systemd[1]: media-bloatlib.automount: Got automount request for /media/bloatlib, triggered by 2254 (pool)
May 04 01:45:29 user-ThinkPad-T510 systemd[1]: Mounting /media/bloatlib...
May 04 01:45:29 user-ThinkPad-T510 mount[2255]: mount error(101): Network is unreachable
May 04 01:45:29 user-ThinkPad-T510 mount[2255]: Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
May 04 01:45:29 user-ThinkPad-T510 systemd[1]: media-bloatlib.mount: Mount process exited, code=exited status=32
May 04 01:45:29 user-ThinkPad-T510 systemd[1]: Failed to mount /media/bloatlib.
May 04 01:45:29 user-ThinkPad-T510 systemd[1]: media-bloatlib.mount: Unit entered failed state.
May 04 01:45:29 user-ThinkPad-T510 kernel: No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.
May 04 01:45:29 user-ThinkPad-T510 kernel: cifs_vfs_err: 6 callbacks suppressed
May 04 01:45:29 user-ThinkPad-T510 kernel: CIFS VFS: Error connecting to socket. Aborting operation.
May 04 01:45:29 user-ThinkPad-T510 kernel: CIFS VFS: cifs_mount failed w/return code = -101

wtf Jow Forums, just installed lubuntu 18.04, and gksu/gksudo are not in the repository. I guess they are intentionally not included any more. What am I supposed to use to launch GUI programs as root?

I can just do sudo su first, then launch the program, but that is an extra 2 steps

Or just install the tarball or .deb from elsewhere online

stop being crybaby and use su or sudo or write a package for gksu/gksudo yourself or kill yourself

thats fucking stupid. A useful program that I regularly use, and many others regularly use, has been removed without a viable alternative.

wtf is the deal

why should I have to do that. gksu is a package that has been around for years and years and been helpful to lots of people and then it was just removed with no replacement. and idiots like you just go "hurr so? durr"

localectl --help

Chances are you're an idiot who didn't even read that guide and just copy pasted things. My guess is that you skipped over the network related part.

Because it had its issues. I'm not an expert, but I think with things like polkit you can fine-tune everything and for example make the program only write a file to disk as root while running the program itself as your user.

>sudo su
Are you retarded?

Here you go, wank stain
if [[ $1 ]]; then
PASSWD="$(zenity --password --title=Authentication)\n"
echo -e $PASSWD | sudo -S [email protected]
zenity --error --text="Put in a command argument to run you piece of fucking shit"

It requires zenity

are you retarded? sudo su is very common, you fucking noob

sudo -i