Why don't people use _ in variable naming?

why don't people use _ in variable naming?

weekly_pay = hours_worked * hourly_pay_rate;

weeklyPay = hoursWorked * hourlyPayRate;

parseDbmXmlFromIPAddress

parse_dbm_xml_from_ipaddress

I really find camelcase hard to read.

Attached: 1538060876058.png (1920x1280, 2.45M)

Plenty of people do. snake_case is reasonably common.

>why don't people use _ in variable naming?
it's called snake case
boost uses it exclusively

determined by the language style

commonly used in python, ruby, elixir (and more)
not used in java, javascript (and more)

follow the style for the language

Attached: pig.jpg (750x560, 59K)

>working with rajesh
>switches naming conventions every other day and constantly misspells shit

Attached: 1537549186710.png (798x448, 306K)

underscore_suck_and_require_an_extra_key_press
anyFormOfSnakeOrWhatEverTheFuckWithCapsSucksBecauseItAlsoRequiresAnExtraKeyPress

this-is-the-only-good-form-since-it-does-not-require-extra-key-presses

common-lisp-for-life

This tbqhfam

N FUCKCOUNT,FUCKTHIS,FUCKOFF
S (FUCKCOUNT,FUCKTHIS)="",FUCKOFF=1
F S FUCKOFF=$O(^FUCK(FUCKOFF)) Q:'FUCKOFF D
.W +$G(^FUCK(FUCKOFF)),!
Q
;if you are familiar with this you already know the problem
;send help
;god speed ye bretheren of EHR conversion

Attached: EQ8QFtFY0BVqSihT63NZx7h-r6gtxGGyc7DS4u3MpBY.jpg (768x768, 135K)

Depends on the project convention. And generally it doesn't increase readability but it costs keystrokes and horizontal space, so it's not as popular as alternatives.

kebab case master race

It's the recommended style in C++ and Python IIRC. Project-level consistency is more important than any particular naming style.

I only see OOPfags using it, so I never name variables that way.

OpIsAFaggot

typing _ slows down your speed massively

Personal preference

camel case requires 1 less keystroke than snake case and is therefore superior
if you can't read it you're dumb

is this npc speak

camel case requires you to press the shift button for each trailing words.
snake case doesn't use shift button.

Because it adds more length to variable name than CamelCase thus it makes harder to keep lines

Why not just call it "parse DBM XML from IP address"? Oh, your language doesn't allow function names with spaces, right?

I used to use the underscore notation, but I prefer camel case these days. It's just easier to type, and I can read it fine.

>function names with spaces
wtf

thank god my language doesnt allow that retarded feature

There is nothing wrong with it and it is very readable.
proc {parse DBM XML from IP address} {ip} {
# Your code here
return
}
{parse DBM XML from IP address} 192.168.69.42

>snake case doesn't use shift button.

Attached: 9E53A9E54A904108AC23EEB664CDC228.jpg (251x242, 15K)

because typing underscore is .00005% more of a pain in the ass then typing a capital letter or dash

ipreferthis becauseyoucan figureoutwhat itmeanscomeon

We should get new unicode character, called programmers space and have spacebar separated in two.

programmers space would show us lower opacity _ in text editor.

Best readability, faster coding.

couldn't you just configure your text editor to make _ more transparent / lighter / darker depending on the background?

I don't like the fact that I need to press ...

Wait... I actually found comfortable way of writing _ with left shift being used... Up until now I only used _ right shifted so it needed to move my hand strange.

Thank you stranger.

CamelCase is garbagio.

Attached: 1536283009724.png (200x164, 10K)

Slugs are good even for pointing cursor with keyboard. I mean hit ctrl and arrows and cursor will jump over words not over whole name.

Because_I_Exclusively_Program_In_Ada

>Fuck up the caps in a variable
>Wasting more time erasing than the sum of the time using _ in a lifetime

>I really find camelcase hard to read.
Stopped reading there

your ment to stop there fagggot

Underscores are undeniably easier to read.

Isn't it camelcase for function names and lower case with underscores for variable names?