OFFICIAL NAMING CONVENTION POWER RANKINGS

1. snake_case

> POWER GAP

2. spinal-case

> POWER GAP

9001. ImAFuckingRetardCase

Attached: dashesunderscorescamel.png (570x200, 5K)

Dashes.

fuckunderscores

none of the above
i just type my function and variable names in all lowercase with no word separation of any kind
i also use abbreviations within said names

ImUsingCamelCaseAndYouCantStopMe.

Snake case is good for showing single depth ownership e.g. car_engine, car_wheels
Spinal case is good for showing nested hierarchies e.g. ocean-mammal-whale, ocean-crustacean-clam
Camel case is good for describing actions e.g. eatCake(), doThing(), getStuff()

You can't program with dashes you retard

HeyIJustMetYou
ThisIsCrazy
HeresMyNumber
SoCallMeMaybe

>he uses a language where you can't program with dashes
imagine the smell

Attached: 88885433-smell-sense-and-human-nose-pictogram.jpg (1300x1300, 47K)

I like this post

>what is bash
exposed yourself

>not using BEM casing

literally lmao@ing at your life

Ip_ReFeRt-OuSeT_h!sM-37OD______

This is the thinking man's naming convention.

That's quite reasonable.

I/like/slashes

or, yknow, whatever the language standard is

Adachads_Roll_Out

Attached: 23FB9E454A974B4BA9A0CE111E521CE1.jpg (774x850, 197K)

>Python and C++: get_remote_directory
>C: getremd
>Java: GetRemoteDirectoryProxyFactory

mAMMOTHcASE

Attached: Christian-Bale-Kiss.gif (350x350, 2.09M)

Nice PascalCase bro

>his language doesn't support space case
yikes

>doesntuse(hatcase);

no;

snake case for everything

pascal case only for structs/types/classes/objects

There is something really appealing about the C way, even though it’s probably always a better idea to write it out

based like a mother fucker

>getremd

Attached: rem.png (1280x720, 706K)

jdfhgfhklfdgjfghd.jpg.png.gif.avi.jpeg

No one likes reaching for the underscore key. Please kill yourself and never program again.

Dashes are nice just because yuo don't have to hit shift to type them. Shame most languages don't support them.

>chicago_sears-tower-view.jpg
Fight me

basedandredpilled

(lisp/lets.you_do*itHowever^you0want)

Hi it’s me COBOL

>fuckunderscores
Snake_case_EVERYWHERE_to_avoid_the_clusterfuck_of_systems_that_can't_handle_spaces.

Spinal-case for nested hierarchies, just like you said. For example, porn-hentai-tentacles.

Camel case when there is a chance that spaces, or even periods/decimals/anything not alphanumeric could f̸̛̛́ú̴̷̀́c̵̀͠͞͝k͡ things u̍̆̄̽͐͐ͦ̈͋̋̈́͐ͣ̋ͬ̊p̒͛͆̎͑ͮͦ͗̈͂̊̿̍.

Attached: ChanInstructions.png (508x355, 14K)

This except never ever use camel case.

thatsNotCamelCaseMoron

maybe dashes and underscores should be switched on keyboards

Attached: 1537779423561.jpg (637x358, 35K)

1
_1
1_
_1_
__1
1__

kebab-case for urls
snake_case for function and variable names
CamelCase for class and file names

%triforce

Idon'tseewhypeopleneedspaces
they'refortheweakminded

Except that you have to write the first letter in lower case, you remind me Windows code style.

i remember when i didnt know about lisp

op&is&a&faggot

ampersand master race

>op&is&a&faggot
which meme languages support spaghetti case?

is this supposed to be a fucking jew?

Attached: cjfjoifuuaeca8i2.jpg (501x504, 72K)

I just use Rust's naming conventions

static UPPER_CASE = "";
let lower_case = "";
struct CamelCase {}
fn lower_case {}
enum CamelCase {}

Fuck you and your kebab case.

I use snake_case, because dashes separate words in text editors.

Underscores or camel case, in that order.
I hate dashes.

C# case all the way.
_privateVariable
publicVariable
ClassName
IClassInterfaceName

Attached: 1464630483037.jpg (640x640, 55K)

This reminds me; I like camel toes.

>I eschew embedded capital letters in names; to my prose-oriented eyes, they are too awkward to read comfortably. They jangle like bad typography.

Attached: Rob-pike-oscon.jpg (1280x853, 38K)

Lol

>snake case is ba-

# i'm guessing this is AI stuff for infantry during battle

# Input: none
# Output: none
siege_move_infantry_to_infantry_positions_new = (
"siege_move_infantry_to_infantry_positions_new",
[
(try_for_agents, ":agent_no"),
(agent_is_alive, ":agent_no"),
(agent_slot_eq, ":agent_no", slot_agent_is_not_reinforcement, 0),
#(agent_is_defender, ":agent_no"),
(agent_get_team, ":team", ":agent_no"),
(this_or_next|eq, ":team", "$defender_team"),
(eq, ":team", "$defender_team_2"),
#(agent_get_class, ":agent_class", ":agent_no"),
(agent_get_troop_id, ":agent_troop", ":agent_no"),
#(neq, ":agent_class", grc_archers),
(try_begin),
(agent_slot_eq, ":agent_no", slot_agent_target_entry_point, 0),
(store_random_in_range, ":random_entry_point", 1, 4),
(val_mul, ":random_entry_point", 10), #10-20-30
(agent_set_slot, ":agent_no", slot_agent_target_entry_point, ":random_entry_point"),
(try_end),
(try_begin),
(agent_get_position, pos0, ":agent_no"),
(entry_point_get_position, pos1, ":random_entry_point"),
(get_distance_between_positions, ":dist", pos0, pos1),
(lt, ":dist", 200),
(agent_clear_scripted_mode, ":agent_no"),
(agent_set_slot, ":agent_no", slot_agent_is_in_scripted_mode, 0),
(agent_set_slot, ":agent_no", slot_agent_is_not_reinforcement, 1),
(str_store_troop_name, s1, ":agent_troop"),
(assign, reg0, ":agent_no"),
# (display_message, "@{s1} ({reg0}) reached pos"),
(else_try),
(try_begin),
(agent_slot_eq, ":agent_no", slot_agent_is_in_scripted_mode, 1),
(agent_clear_scripted_mode, ":agent_no"),
(agent_set_slot, ":agent_no", slot_agent_is_in_scripted_mode, 0),
(str_store_troop_name, s1, ":agent_troop"),
(assign, reg0, ":agent_no"),
# (display_message, "@{s1} ({reg0}) seeing target or changed mode"),
(try_end),
(try_end),
(try_end),
])

why always they say agent_no why never say agent_yes

agent number

>snake_case
for python
>RetardCase
for function names
>camelCase
for basically everything else
>spinal-case
only for HTML class/id names
>CONST_CASE
for constants

Attached: 1534823566582.jpg (500x375, 62K)

Snek a best girl

>_HE-doesnt-EVEN_alternate
your life must suck

likewise

>greentext
it𝑎lic
Bold
●item 1
●item 2
●item 3

Z̨̼͉̺̝ͩͮ̔̓ͩ͝A̬̩͚͚̦͑ͧ̀͌͂͜L̸̟̼̯͍̥͍̋͠G̴̹͖̤̀̾̃͂̓͟O̻͔͖̽̔́̄ͪ̏ͮ͛

if 𝟷*𝟸

Attached: 1551971908954.gif (400x480, 124K)

agent_num
The word number doesn't even have an "o" in it.

_-Why_-Alternate_-When_-You_-can_-Have_-Everything_-At_-The_-Same_-Time_-?

int main()
{
int m = 1000;
unsigned long long S = 2;
char *s =calloc(m / 2 - 1, sizeof(char));
if (!s) return 1;
for (int i = 0; i < m / 2 - 1; ++i) {
if (!s[i]) {
S += 2 * i + 3;
for (int j = 3 * i + 3; j < m / 2 - 1; j += 2 * i + 3) {
s[j] = 1;
}
}
}
printf("%llu\n", S);
free(s);
return 0;
}

>dashes
files?

descriptive-information--different-kind-descriptive-information.extension
e.g. layout-home--website-project-name--2019-03-12--14-32.ai

I use emojis for PHP variables too, like
$[:smiley]

0. Laconic

spinal-case-a-best

NOT+PLUS+CASE+FAGGOTS

0. the chad space case.txt

spinal case for files, especially in nix systems

>fuckunderscores
This is okay.
In descending order, dashes are better than camel, camel is better than underscores.
Continuing the descent:
>getremd
This is starting to get bad.
>Hungarian
The suffering is unbearable.
>leading underscores
What are you even doing.

r.dot.case

~/.config/i3wm/gaps/usr/share/tor-browser-bundle/user/downloads/Adobe/templates/epicmemes/example/docs/gentoo_vm_disc/root/bin/notcp/gcc.bin

snaked_camelCase

$tHE_bEST-sTYLE

snake case even before rustfmt autistically enforced it

You don't even need rustfmt for that - the compiler itself will bitch about your naming by default. You have to put #![allow(nonstandard_style)] on your crate if you want to disable it (previously called #![allow(bad_style)], but that name is deprecated due to being too judgemental)

You must be a joy to work with.

I'm nearly 6 years into my software career and both haven't seen and didn't know you could name variables with dashes.

Attached: 1522988770871.png (671x519, 146K)

Yeah that's because nobody does it because it's retarded. That convention is only ever used with files.

Lisp and Perl6 can

spaces

GOTEMMMM

Based CIA negro. Ada 2020.

Attached: 1514408950966.gif (194x172, 495K)

reddit_spacing